Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 06, 2016, 10:46:20 22:46


Login with username, password and session length


Pages: [1]
Print
Author Topic: avr + 1wire  (Read 3082 times)
0 Members and 1 Guest are viewing this topic.
max_buddy
Guest
« on: May 19, 2008, 07:46:47 19:46 »

hi
i'm having a problem with a ds18b20 sensor and an atmega8l @ 4mhz (tested at 8 too).

 testing using bascom and the device enumeration (1wirecount function) returns 0 devices. also the err value is 1.
the exact problem appears on bascom's website but without a solution. i have tested with 2 sensors so i't not likely both are broken.

http://www.mcselec.com/index2.php?option=com_forum&Itemid=59&page=viewtopic&t=762&highlight=1wirecount

http://www.mcselec.com/index2.php?option=com_forum&Itemid=59&page=viewtopic&t=1673&highlight=1wirecount

http://www.serasidis.gr/forums/forum_posts.asp?PN=1&TID=70

the sensor is properly connected, there is a pull-up resistor and so on. anyone has another idea?
many thanks
Logged
karthikeyan_sw
Newbie
*
Offline Offline

Posts: 7

Thank You
-Given: 1
-Receive: 5


« Reply #1 on: May 19, 2008, 08:19:06 20:19 »

put a scope to grab the signals if you dont have scope then create the same circuit in proteus simulator and then try debugging using the oscilloscopes.
Logged
max_buddy
Guest
« Reply #2 on: May 20, 2008, 10:35:00 10:35 »

too bad i don't have a scope... it works in proteus
so probably i've got 2 broken sensors.... damn
Logged
bugmike25
Junior Member
**
Offline Offline

Posts: 84

Thank You
-Given: 15
-Receive: 13


« Reply #3 on: May 20, 2008, 07:16:37 19:16 »

Because it works in Proteus deos not mean it works on your hardware.  I designed and tested an 8051 MCU interfaced with a DS18S20 temp. sensor.  It worked fine on the hardware but didnt work when tested using proteus.  The best way to check if the sensors are damaged is by using a scope and see if the output voltage is changing on the data line.
Logged
max_buddy
Guest
« Reply #4 on: May 21, 2008, 12:12:12 12:12 »

ok, thanks for replys
i'll try to get my hands on a scope to check the sensors
Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC