Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 06, 2016, 11:04:12 11:04


Login with username, password and session length


Pages: [1]
Print
Author Topic: Microchip Zigbee stack, bind problem  (Read 1729 times)
0 Members and 1 Guest are viewing this topic.
TWISTED
Inactive

 Muted
Offline Offline

Posts: 3

Thank You
-Given: 2
-Receive: 7


« on: April 15, 2011, 10:37:29 10:37 »

I added this case in the zigbeeRes code... im using icd2 to debug when the condition: in (zAPS.c)
  
if( APSFromLongToShort( &params.APSME_BIND_request.DstAddr.LongAddr ) == FALSE ) //<- true
 {
  params.APSME_BIND_confirm.Status = BIND_ILLEGAL_DEVICE;  
 return APSME_BIND_confirm;
 }
I real dont know whats wrong,  the function "APSFromLongToShort" should put the short address in currentAPSAddress.shortAddr and im sure the that the entry of the device (router) is in the neighboring table (i can see it when i dump the neighborTable)
If anyone have an idea plz tell me..
MY CODE:
Code:
       case '9':
          GetMACAddress(&params.APSME_BIND_request.SrcAddr);
          params.APSME_BIND_request.DstAddrMode    = APS_ADDRESS_64_BIT;
          params.APSME_BIND_request.DstAddr.LongAddr.v[7] = 0x00;
          params.APSME_BIND_request.DstAddr.LongAddr.v[6] = 0x00;
          params.APSME_BIND_request.DstAddr.LongAddr.v[5] = 0x00;
          params.APSME_BIND_request.DstAddr.LongAddr.v[4] = 0x01;
          params.APSME_BIND_request.DstAddr.LongAddr.v[3] = 0x00;
          params.APSME_BIND_request.DstAddr.LongAddr.v[2] = 0x00;
          params.APSME_BIND_request.DstAddr.LongAddr.v[1] = 0x00;
          params.APSME_BIND_request.DstAddr.LongAddr.v[0] = 0x00;
                      
          params.APSME_BIND_request.ClusterId.Val  = TRANSMIT_COUNTED_PACKETS_CLUSTER;
          params.APSME_BIND_request.SrcEndpoint    = 1;
          params.APSME_BIND_request.DstEndpoint    = 240;
                  
          currentPrimitive = APSME_BIND_request;
        
                  break;
Thank you regards.
« Last Edit: April 15, 2011, 10:41:29 10:41 by TWISTED » Logged
ALLPIC
V.I.P
Active Member
*****
Offline Offline

Posts: 113

Thank You
-Given: 64
-Receive: 72


« Reply #1 on: May 26, 2011, 05:53:56 05:53 »

is it zigbee 2006 or miwi?
Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC