Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 07, 2016, 11:30:29 11:30


Login with username, password and session length


Pages: [1]
Print
Author Topic: New avr-gcc4.3.3 Linux buildscript on AVR Freaks  (Read 2287 times)
0 Members and 1 Guest are viewing this topic.
Mega32
Active Member
***
Offline Offline

Posts: 175

Thank You
-Given: 71
-Receive: 38


« on: June 18, 2009, 07:01:05 19:01 »

Hi

Just saw that there is a new linux buildscript for avr-gcc 4.3.3 , with xmega support on AVR Freaks

http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=42631

Mega32
« Last Edit: June 19, 2009, 12:10:04 00:10 by bbarney » Logged
metal
Global Moderator
Hero Member
*****
Offline Offline

Posts: 2018

Thank You
-Given: 514
-Receive: 477


Top Topic Starter


« Reply #1 on: June 18, 2009, 08:05:16 20:05 »

Let me understand why you are posting a real old thread in AVR freaks ?
« Last Edit: June 18, 2009, 08:09:20 20:09 by metal » Logged

nothing to say..
Mega32
Active Member
***
Offline Offline

Posts: 175

Thank You
-Given: 71
-Receive: 38


« Reply #2 on: June 18, 2009, 08:50:44 20:50 »

@Metal

Sure it was today or yesterday that the buildscript was updated to gcc 4.3.3 , witch have support for all the new xmega chips.

Before that  the script only made gcc 4.2.2 , witch did not have support for all the new xmega chips

Even thoug the thread is old , it is always updated with the lates linux avr-gcc build.

See the announcement message here , and note the date on the announcement.
http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=80442

So i did post about a new version in an old thread.

It would come in handy for the linux based avr developers that are here

Mega32
don't code your links
« Last Edit: June 19, 2009, 12:09:36 00:09 by bbarney » Logged
Mega32
Active Member
***
Offline Offline

Posts: 175

Thank You
-Given: 71
-Receive: 38


« Reply #3 on: August 12, 2009, 08:42:37 20:42 »

Just saw there is a new buildscript , fixing some problems in the old one.
http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=82697

They say : Rebuild the toolchain

Mega32
Logged
Mega32
Active Member
***
Offline Offline

Posts: 175

Thank You
-Given: 71
-Receive: 38


« Reply #4 on: March 06, 2010, 07:05:23 19:05 »

If you use Ubuntu or are able to install a .deb package (ie. redhat alien)

I just noticed there is a new Ununtu Debian install package , with all the patces from the current WinAVR 2010 release. It seems to instalĺl & work on both 32 & 64 bit.

See
http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=90241


There are som additional install hints here , from an earlier release.
http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=90172

Download the avr-gcc-4.3.3-avrfreaks-25-feb-2010-special-static.deb package
http://www.wrightflyer.co.uk/avr-gcc/


Mega32
« Last Edit: March 07, 2010, 04:33:00 16:33 by Mega32 » Logged
Mega32
Active Member
***
Offline Offline

Posts: 175

Thank You
-Given: 71
-Receive: 38


« Reply #5 on: May 04, 2010, 09:04:17 21:04 »

New Ubuntu 10.04 .deb packages on http://www.wrightflyer.co.uk/avr-gcc/

This time for both 32-bit & 64-bit systems

avr-gcc-4.3.4-avrfreaks-30-apr-2010-u10.04.i386.deb
avr-gcc-4.3.4-avrfreaks-30-apr-2010-u10.04.x64.deb

Mega32
Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC