Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 05, 2016, 05:37:08 17:37


Login with username, password and session length


Pages: [1] 2  All
Print
Author Topic: patch for Hitech picc std v9.60pl2  (Read 18492 times)
0 Members and 1 Guest are viewing this topic.
mitsos
Senior Member
****
Offline Offline

Posts: 449

Thank You
-Given: 1570
-Receive: 683


« on: July 12, 2008, 03:59:13 15:59 »

hi

get from:
http://rapidshare.com/files/129138596/Patch.exe.html

regards
mitsos
Logged
xxtigerxx
Newbie
*
 Muted
Offline Offline

Posts: 14

Thank You
-Given: 3
-Receive: 1


« Reply #1 on: July 14, 2008, 08:43:38 08:43 »

can anyone link 9.60 of the demo..

:-)

Logged
omni
Active Member
***
Offline Offline

Posts: 139

Thank You
-Given: 163
-Receive: 167


« Reply #2 on: July 15, 2008, 01:37:47 01:37 »

Is this patch for a demo or for the update version ?

If for the update version, where can we get it? Smiley
Logged
mitsos
Senior Member
****
Offline Offline

Posts: 449

Thank You
-Given: 1570
-Receive: 683


« Reply #3 on: July 15, 2008, 07:45:23 19:45 »

hi

it is for the "downloadable" demo from hitech site.

mitsos
Logged
0sLtEd43bZ5z
Guest
« Reply #4 on: July 24, 2008, 10:56:03 10:56 »

Hi, does anyone know if this patch works also for HI-TECH C PRO for the PIC10/12/16 MCU Family ANSI C COMPILER v9.60PL2?
Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #5 on: July 28, 2008, 10:45:07 22:45 »

No, it doesn't..... but someone may fix it?
Logged

Code Warrior
wessoms
Junior Member
**
Offline Offline

Posts: 35

Thank You
-Given: 14
-Receive: 44


« Reply #6 on: July 29, 2008, 09:33:45 21:33 »


Have not tried 100%


http://rapidshare.com/files/133398949/PICC_PRO_9_6_0.rar.html


enjoy..

Posted on: July 29, 2008, 09:30:48 21:30 - Automerged

Password Sonsivri

Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #7 on: July 30, 2008, 12:42:30 00:42 »

Seems to work OK. But it reports the version to be 9.60PL3. Never mind.
Thanx...
Logged

Code Warrior
edalab
Guest
« Reply #8 on: July 30, 2008, 03:08:34 03:08 »

only work at lite mode.

Posted on: July 30, 2008, 03:07:27 03:07 - Automerged

please continue to work for crack picc pro for pic16
Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #9 on: July 30, 2008, 01:18:10 13:18 »

It's working for me. What's the problem?
Logged

Code Warrior
0sLtEd43bZ5z
Guest
« Reply #10 on: July 30, 2008, 01:26:37 13:26 »

robban are you sure, it's not working in lite mode?
Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #11 on: July 30, 2008, 01:46:53 13:46 »

I think You must have enabled "Operate in lite mode" when You set up the compiler. Use 45 days evaluation instead.
Logged

Code Warrior
mbandala
Senior Member
****
Offline Offline

Posts: 271

Thank You
-Given: 123
-Receive: 304



« Reply #12 on: July 30, 2008, 02:13:54 14:13 »

Have not tried 100%
http://rapidshare.com/files/133398949/PICC_PRO_9_6_0.rar.html
enjoy..

Posted on: July 29, 2008, 09:30:48 21:30 - Automerged

Password Sonsivri

Guys!
You have not noticed it? wessoms indeed uploaded PICC v9.60pl3 but it is the PRO version. I have fully tested and works OK. This is really something and I am very satisfied...

I just uninstalled my STD v9.60pl1 installation, installed this one and didn't have to change anything in MPLAB. I was able to compile my codes by just clicking the BUILD button.

Posted on: July 30, 2008, 01:58:31 13:58 - Automerged

I think You must have enabled "Operate in lite mode" when You set up the compiler. Use 45 days evaluation instead.
Yes, better try the 45 days evaluation mode. Though I tried the Lite mode and it worked. At least you should be able to compile any existing work in either Lite or evaluation modes. The problem has to be related to the configuration of the compiler in MPLAB. You should probably get a source file successfully compiled with a previous version of PICC and then try this new version with your working code.
Logged

Feel free to press "thank you" if you think you have found something useful! -^
0sLtEd43bZ5z
Guest
« Reply #13 on: July 30, 2008, 02:15:54 14:15 »

Hi,

i tried to install this cracked PL3 version, however at installation, I get feedback "Your evaluation period has expired (139402)". I actually did use up 45 days on older (not cracked) version of the compiler. This feeback appears after checking (connecting with Hi-tech server) in installation mode. I cannot proceed with instalation even if I disconnect computer. Does anybody know based on which property, Hi-tech checks which computer am I using. MAC or hard disk serial number or something else. I'm pretty sure Hi-tech has some kind of database, based on which it checks from which computer installation is runned.

Can perhaps anybody crack installation file, not to check online for previous installations?
Logged
wessoms
Junior Member
**
Offline Offline

Posts: 35

Thank You
-Given: 14
-Receive: 44


« Reply #14 on: July 30, 2008, 03:28:06 15:28 »


For the PICC PRO 9.60PL3 :

If your 45 day period has been previously used then install the lite version, copy the file over and it will work in PRO mode. If you have the picc pro 9.60PL3 version already installed just copy the picc.exe in the download over the one installed.
Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #15 on: July 30, 2008, 03:32:03 15:32 »

The only thing I can think of is that Yr. time and calendar is not updated, or Yr. registry is clogged up.You can manually remove any entries by searching it for "HI-TECH" or use a registry cleaner that remove any void entry.
... good luck.
Logged

Code Warrior
mitsos
Senior Member
****
Offline Offline

Posts: 449

Thank You
-Given: 1570
-Receive: 683


« Reply #16 on: July 31, 2008, 12:18:40 00:18 »

hi

I think the only feature of the cracked picc.exe is to hide the lite mode when executed.
By no way works at the pro mode with ocg enabled.

I notice the following (using command line, I choose 16f877)
compiling the led.c from the samples folder
on picc pro 9.60pl3 compiler
with the genuine picc.exe I take a hex file that waste 69 memory places (lite mode)
with cracked picc.exe      I take again a hex file with 69 memory places   ("virtual" pro mode)
on picc std 9.60pl2 compiler (cracked)
without optimization I take a hex file that waste 49 memory places
with full otimization I take a hex file that waste 25 memory places

it seems that hitech to give a good impession about the ocg optimiser, "destroy" the picc pro compiler to produce larger size of code comparing to std version without optimization.

regards
mitsos

ps I hope kappa do the right job
Logged
mbandala
Senior Member
****
Offline Offline

Posts: 271

Thank You
-Given: 123
-Receive: 304



« Reply #17 on: July 31, 2008, 01:56:50 01:56 »

with the genuine picc.exe I take a hex file that waste 69 memory places (lite mode)
with cracked picc.exe      I take again a hex file with 69 memory places   ("virtual" pro mode)
on picc std 9.60pl2 compiler (cracked)
without optimization I take a hex file that waste 49 memory places
with full otimization I take a hex file that waste 25 memory places

I just tried led.c and got this from the compiler using 16F873 in MPLAB

Memory Summary:
    Program space        used    15h (    21) of  1000h words   (  0.5%)

It used only 21 bytes. It looks like my copy of PICC PRO 9.60pl3 is working with OCG. Am I wrong?
Logged

Feel free to press "thank you" if you think you have found something useful! -^
mitsos
Senior Member
****
Offline Offline

Posts: 449

Thank You
-Given: 1570
-Receive: 683


« Reply #18 on: July 31, 2008, 06:45:50 18:45 »

hi

can you give us more info about what mplab version you have, what settings in build options are you use as here with mplab v8.1 and various compilers from hitech installed I take a hex with 77 memory places with the 16f873. Something going wrong so I must solve it.

regards
mitsos
Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #19 on: August 01, 2008, 02:30:30 02:30 »

I just tried the LCDemo in samples folder(where do You find the LED example?) and the PRO version used roughly 20 % lower hexfile than the standard version...
Logged

Code Warrior
0sLtEd43bZ5z
Guest
« Reply #20 on: August 01, 2008, 09:54:54 09:54 »

Hi, I tried compiling one of my small projects with lite and cracked PL3 version and noticed a slight difference in code size. It changed from 476 bytes (lite) to 461 (cracked pro).
Not much difference, however project is very simple (1 source file, no interrupts...).
I have installed compiler in lite mode, because I used up 45days in evaluation pro mode...
So I guess crack works also in lite mode.
Logged
mitsos
Senior Member
****
Offline Offline

Posts: 449

Thank You
-Given: 1570
-Receive: 683


« Reply #21 on: August 01, 2008, 10:29:43 10:29 »

hi

I try everything in my place:
I try mplab version 8 and 8.1, I install the picc pro 9.60 pl3 by all ways eval 45,lite then with doctor cleaner I clean registry errors (is there a better program for this job?) but everytime I take a hex file with 69 memory places to 16f877 against 25 with picc std 9.60pl2 with full optimization, when compiling the led.c in the misc folder of samples

Can you tell me which mplab are you using, what type of installation you choose at the picc pro as the problem is not solved.

regards
mitsos
Logged
robban
Senior Member
****
Offline Offline

Posts: 265

Thank You
-Given: 34
-Receive: 38


Warrior


WWW
« Reply #22 on: August 01, 2008, 11:06:25 11:06 »

Well, this needs to be solved...

Which environment are Yr. machine running on? The problem is not obvious to me, at least. Remember though, if You have PIC:s as a hobby, optimization is for those who need to upgrade an existing PIC where a change of MCU will be costly. Someone else mentioned a pro uninstaller which could be handy in this case since some fragments still linger in Yr. temp folders.
Myself I don't care much for Vista since it's not a significant change from XP(only mor RAM and CPU power needed). I think You need to tell us Yr. environment and the steps toward failure.

Another thing: If you are able to port HI-TECH code to Knudsen CC5X(red edition, found elsewhere in this forum) You'll be amazed how compact the code will be.
Logged

Code Warrior
0sLtEd43bZ5z
Guest
« Reply #23 on: August 01, 2008, 11:25:39 11:25 »

I don't think registry(or any other installation traces) has anything with detecting previous installations. Hi-tech has some kind of database, with some of comuter unique values (MAC or HD ID) so at each installation it checks this database (as far as I noticed, you cannot install evaluation version without net access). But if you install in lite mode, you should be able to use cracked version. I did anyway.
Logged
mbandala
Senior Member
****
Offline Offline

Posts: 271

Thank You
-Given: 123
-Receive: 304



« Reply #24 on: August 01, 2008, 07:09:42 19:09 »

hi

can you give us more info about what mplab version you have, what settings in build options are you use as here with mplab v8.1 and various compilers from hitech installed I take a hex with 77 memory places with the 16f873. Something going wrong so I must solve it.

regards
mitsos
Sorry you are struggling with this. I suppose I was lucky anyway. I just installed the 45-day trial and applied the crack. Then created a new project in MPLAB 8.0 (Device=16F873), selected the HI-TECH Universal Tool Suit and added LED.c (which is located in C:\Program Files\HI-TECH Software\PICC\PRO\9.60\samples\misc). I did not change anything in the build options, just clicked the "rebuild" button and got the screen I am attaching. You can clearly see that OCG seems to work for me. I hope you can reproduce this result. Just keep trying.

Posted on: August 01, 2008, 07:03:02 19:03 - Automerged

I honestly don't think that the MPLAB version matters. Just remember to crack the 45-day trial. I tried the Lite mode and that didn't work... I'm using XP SP2 if it helps...
Logged

Feel free to press "thank you" if you think you have found something useful! -^
Pages: [1] 2  All
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC