Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 18, 2018, 11:06:26 23:06


Login with username, password and session length


Pages: [1]
Print
Author Topic: Zhongdi ZD-987 help wanted to repair  (Read 1205 times)
0 Members and 1 Guest are viewing this topic.
mitsos
Hero Member
*****
Offline Offline

Posts: 540

Thank You
-Given: 1942
-Receive: 969


« on: August 27, 2018, 03:41:12 15:41 »

hi

I use the last years this cheap station and suddenly the desoldering part is no more working.
After power on, every second, all segments of LCD are tuning on and a beep is sounding for a moment.
The desoldering gun is no heating.

I reverse engineering the microcontoller pcb, ZD-LTY-2, it uses the C8051F310.

The soldering part is working OK. Is there a way to read the contents of C8051F310?

regards
mitsos
« Last Edit: August 30, 2018, 10:00:18 10:00 by mitsos » Logged
h0nk
Active Member
***
Offline Offline

Posts: 157

Thank You
-Given: 124
-Receive: 105



« Reply #1 on: August 27, 2018, 04:21:16 16:21 »


Hello mitsos,

there is a C2 interface for 51er Silicon Labs Controller.
Look for Silicon Labs Applikation Note AN127.

I bought a cheap clone of the JTAG/ISP-Adapter on Ebay.
It works well.

But i am afraid that the security options are set and
Flash Read-Out is prohibited.


Good Luck, and

Best Regards
Logged
fpgaguy
Active Member
***
Offline Offline

Posts: 111

Thank You
-Given: 111
-Receive: 114


« Reply #2 on: August 28, 2018, 12:36:31 12:36 »

there's a couple teardowns of this device with suggestions to improve
usually this is a heating element or pump problem and not the micro
Logged
pickit2
Moderator
Hero Member
*****
Offline Offline

Posts: 4119

Thank You
-Given: 660
-Receive: 2456


There is no evidence that I muted SoNsIvRi


« Reply #3 on: August 29, 2018, 04:54:17 04:54 »

This maybe a starting point.
https://www.eevblog.com/forum/chat/firmware-for-zd915-solder-station-converter-in-hex/msg1221804/#msg1221804
Logged

Note: A forum without posters is not a forum. posts of no value to topic maybe deleted
bigtoy
Active Member
***
Offline Offline

Posts: 190

Thank You
-Given: 192
-Receive: 257


« Reply #4 on: August 29, 2018, 09:46:36 09:46 »

I had problems with my cheap Chinese hot-air desoldering system. I took the handle apart. Turned out there was a thermal fuse up close to the heating element in the handle. And it had done what thermal fuses often do - it went open-circuit. I just bypassed it and the unit started working again.
Logged
mitsos
Hero Member
*****
Offline Offline

Posts: 540

Thank You
-Given: 1942
-Receive: 969


« Reply #5 on: August 30, 2018, 09:58:25 09:58 »

hi

I upload a small video to see the fault here:
https://we.tl/t-D10ME6I8s1

you'll see after power-on that in every flashing displays for a moment the working temperature 440C and then go to faulty operation forever, either the gun is connected or not.

I attach the power PCB. When I force 3V through a 300ohm resistor to optocoupler pin 1, the gun is starting to heat.
I ask also the Zhongdi for this fault.

regards
mitsos
« Last Edit: September 01, 2018, 02:07:49 02:07 by mitsos » Logged
pickit2
Moderator
Hero Member
*****
Offline Offline

Posts: 4119

Thank You
-Given: 660
-Receive: 2456


There is no evidence that I muted SoNsIvRi


« Reply #6 on: August 30, 2018, 12:05:19 12:05 »

Both controller pcbs are the same. only the code is different.
the unsoldering gun has an extra pin for the trigger, your heater seams to work.
how about the thermistor.

I looked if the workshop stores to see if they had any scraped zd915's
but they have been moved, the store keeper is away on holiday for another two weeks.
Logged

Note: A forum without posters is not a forum. posts of no value to topic maybe deleted
mitsos
Hero Member
*****
Offline Offline

Posts: 540

Thank You
-Given: 1942
-Receive: 969


« Reply #7 on: August 30, 2018, 01:21:26 13:21 »

hi

I forget to write some notes:

the resistor of 120k, at the feedback of 358, is present only on the desoldering control PCB

the value of VRA1 comes from measurement

I take measurements on thermocouple from the soldering part, I find about 74microvolt/C and the gain of 358 is about 65. With Vref=2.5V you get a maximum temperature 520C.

The gun has a smart sensor of "busy" station,the SW-18010P from SUR (on net you find the same from SOYO), it is a spring that has at its centre a piece of wire. The spring action is like an inverted pendulum and as it vibrates, during working with the gun, it touches the wire. It is a simple switch that put the pin P1.4, through a resistor RA1 with value 1kohm (not appeared in my schematics), to earth. If for 15 minutes the spring is not touch the wire, the C8051 set the temperature to 200C.

The small fan (not appeared in my schematics) gets its supply with half rectification like D2 and E1 in the control PCB schematic.

regards
mitsos
« Last Edit: September 01, 2018, 10:59:07 10:59 by mitsos » Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC