The Godfather talking
Share your stuff or I will make you regret it.
Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
July 21, 2018, 10:06:40 10:06


Login with username, password and session length


Pages: [1]
Print
Author Topic: Solved - Arduino + SIM800L + GPS NEO-6M - Error in AT+HTTPACTION=1  (Read 406 times)
0 Members and 1 Guest are viewing this topic.
nagkiller
Newbie
*
Offline Offline

Posts: 13

Thank You
-Given: 66
-Receive: 3


« on: July 01, 2018, 02:50:30 02:50 »

Hi.

A very strange error in my project using the Arduino + SIM800L + GPS NEO-6M.

When I am using the SIM800L connected in the usb converter, the AT commands work without errors.

But when I connect the SIM800L on the Arduino board, behold the error happens.

This error occurs if you use the POST or GET method.

Code:
String address = "http://dweet.io/dweet/for/test800?var1=1234&var2=ABC&var3=1A2B3C";

gsm.println("AT");
gsm.println("AT+CSCLK=0");
Serial.println("AT+SAPBR=3,1,Contype,GPRS");
gsm.println("AT+SAPBR=3,1,APN," + apn);
gsm.println("AT+SAPBR=3,1,USER," + apnUser);
gsm.println("AT+SAPBR=3,1,PWD," + apnPass);
gsm.println("AT+SAPBR=1,1");
gsm.println("AT+HTTPINIT");
gsm.println("AT+HTTPPARA=CID,1");
gsm.println("AT+HTTPPARA=URL," + address);
gsm.println("AT+HTTPPARA=CONTENT,application/x-www-form-urlencoded");
gsm.println("AT+HTTPDATA=2,1000");
gsm.println("AT+HTTPSSL=0");
gsm.println("AT+HTTPACTION=1");
gsm.println("AT+HTTPREAD");
gsm.println("AT+HTTPTERM");
gsm.println("AT+CSCLK=2");
gsm.println("AT");


In each line has a delay of 100ms, after AT+HTTPACTION=1 has 1 second delay.

Address is http://dweet.io/dweet/for/test800?var1=1234&var2=ABC&var3=1A2B3C and the data can be viewed in https://dweet.io/get/dweets/for/test800.

If I use a browser and put the Address, work fine, in Arduino board that is not possible.

This is the log message:

Code:
AT

OK
AT+CSCLK=0

OK
AT+SAPBR=3,1,Contype,GPRS

OK
AT+SAPBR=3,1,APN,myApnName

OK
AT+SAPBR=3,1,USER,apnUsername

OK
AT+SAPBR=3,1,PWD,apnPassword

OK
AT+SAPBR=1,1

OK
AT+HTTPINIT

OK
AT+HTTPPARA=CID,1

OK

AT+HTTPPARA=CONTENT,application/x-www-form-urlencoded

OK
AT+HTTPDATA=2,1000

DOWNLOAD

OK
AT+HTTPSSL=0

OK
AT+HTTPACTION=1

ERROR
AT+HTTPREAD

OK
AT+HTTPTERM

OK
AT

OK


Can someone help me, please.

Posted on: July 01, 2018, 02:08:26 02:08 - Automerged

I'm thinking that the url is too big, and that's what's causing the problem...

Posted on: July 01, 2018, 02:34:56 02:34 - Automerged

Problem Solved!!!!

Too Bigger address...
« Last Edit: July 01, 2018, 02:58:39 02:58 by nagkiller » Logged

(\ /)
( . .)
c(")(") This is Bunny. Copy and paste Bunny into your signature to help him gain world domination.
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC