The Godfather talking
This is god damn my place! Capisci?
Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 03, 2016, 10:48:07 22:48


Login with username, password and session length


Pages: [1]
Print
Author Topic: PBP: Just when you thought it was dead  (Read 1469 times)
0 Members and 1 Guest are viewing this topic.
towlerg
V.I.P
Active Member
*****
Offline Offline

Posts: 136

Thank You
-Given: 282
-Receive: 48

What is this for?


« on: June 27, 2015, 05:27:06 17:27 »

a new version after several years

Quote
Added support for devices: 16(L)F1454, 16(L)F1458, 16(L)F1459, 12(L)F1571, 16(L)F1572,
16(L)F1574, 16(L)F1575,16(L)F1578, 16(L)F1579, 12(L)F1612, 16(L)F1613, 16(L)F1614, 16(L)F1615,
16(L)F1618, 16(L)F1619, 16(L)F1703, 16(L)F1704, 16(L)F1705, 16(L)F1707, 16(L)F1708, 16(L)F1709,
16(L)F1713, 16(L)F1716, 16(L)F1717, 16(L)F1718, 16(L)F1719, 16(L)F1764, 16(L)F1765, 16(L)F1768,
16(L)F1769, 16LF1554, 16LF1559, 16(L)F18313*, 16(L)F18323*, 16(L)F18325*, 16(L)F18345*, 16F753,
16HV753, 18F97J94, 18F87J94, 18F67J94, 18F96J99, 18F86J99, 18F66J99, 18F96J94, 18F86J94,
18F66J94, 18F95J94, 18F85J94, 18F65J94
* preliminary support, no datasheet available at time of build

Removed support for 16F527 (device not currently compatible with PBP)

Fixed HPWM for 16(L)F1788, 1789
Suppressed error 311 for K50 parts with PBPL
Fixed WRITECODE block size for 16(L)F1946, 1947
Added message concerning use of high-level commands on PORTF/G on 16(L)F1946/7, 16(L)F1526/7, 16F946

The following devices are not currently compatible with PBP: 10F200, 10F204, 10(L)F320, 10(L)F322, 12F520, 16F527, 16F570, 16(L)F18855, 16(L)F18875
George
Logged

Win 7 Ult x86 SP1 on HP6910p
Cain
Junior Member
**
Offline Offline

Posts: 90

Thank You
-Given: 102
-Receive: 106


« Reply #1 on: June 03, 2016, 09:18:20 09:18 »

Just for clarification, above is PBP 3.0.8.

The latest version are 3.09. Anyone using it?

Quote
Fixes a critical issue in ON INTERRUPT / RESUME when using 12F1xxx/16F1xxx devices.
For newest device support, PBP requires that  MPLABX be downloaded from Microchip and installed.
This version is compatible with MPLAB8, but the newest devices aren't supported by the older MPASMWIN assembler.
Download includes PBP, MicroCode Studio, and MicroCode Studio Plus (product key required for MCSP)
« Last Edit: June 03, 2016, 09:36:22 09:36 by Cain » Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC