Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 08, 2016, 03:10:43 15:10


Login with username, password and session length


Pages: [1]
Print
Author Topic: Pic18F4680 - CCS+MPLAB+Proteus and Data EEProm issues past address FF  (Read 2195 times)
0 Members and 1 Guest are viewing this topic.
icecubetray
Newbie
*
Offline Offline

Posts: 14

Thank You
-Given: 3
-Receive: 0


« on: February 13, 2009, 06:51:48 18:51 »

I am using the CCS compiler, MPLAB and Proteus and using a Pic18F4680

When I used the read_eeprom function
eg. read_eeprom(256) or read_eeprom(0x100)

it always returns the contents of address 0x00

My next step will be to try this in hardware, but has anyone run across a problem like this?

I have a Data eeprom file that I saved on my harddisk and this is what I load to Data eeprom, via MPLAB.

I can't really tell whether this is a compiler issue, MPLAB or proteus issue.

I'm hoping that by doing this on the hardware it will tell me if its a compiler/MPLAB issue or Proteus issue.
Logged
spasbyspas
Active Member
***
Offline Offline

Posts: 169

Thank You
-Given: 663
-Receive: 364


« Reply #1 on: February 13, 2009, 08:37:01 20:37 »

Yes man! The problem is hardware - Proteus bug - can'not adressed more than 256 byte of internal EEPROM!
Logged
icecubetray
Newbie
*
Offline Offline

Posts: 14

Thank You
-Given: 3
-Receive: 0


« Reply #2 on: February 13, 2009, 10:10:19 22:10 »

Cool thank you!

you just saved me lots of time Smiley
Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC