Sonsivri
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 11, 2016, 10:53:12 10:53


Login with username, password and session length


Pages: [1]
Print
Author Topic: WHAT IS PROBLEM  (Read 935 times)
0 Members and 1 Guest are viewing this topic.
aamir
Hero Member
*****
 Muted
Offline Offline

Posts: 510

Thank You
-Given: 37
-Receive: 229


« on: August 20, 2008, 08:04:47 08:04 »

I am new to avr I am using ATMEGA8515 .When I program AVR program is running when micro controller is inserted in ISP parallel port  programmer. But when I remove it  from programmer and use it simple testing board AVR does not work.What is problem.
Logged
otter
V.I.P
Junior Member
*****
Offline Offline

Posts: 56

Thank You
-Given: 195
-Receive: 2


« Reply #1 on: August 20, 2008, 02:27:39 14:27 »

That sounds strange. Check the fuses (although I can't think what would give that effect, but it is where this kind of problem could be controlled from). With the programmer removed, is the reset pin high?
You could try putting in a really simple program, just to make sure the program is working as you think it is, and see if that works when the programmer is removed.
Are you using a bootloader or starting the program at 0000? This is an area of the fuses that does cause problems.
Regards
Otter
 
Logged
Pages: [1]
Print
Jump to:  


DISCLAIMER
WE DONT HOST ANY ILLEGAL FILES ON THE SERVER
USE CONTACT US TO REPORT ILLEGAL FILES
ADMINISTRATORS CANNOT BE HELD RESPONSIBLE FOR USERS POSTS AND LINKS

... Copyright 2003-2999 Sonsivri.to ...
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines LLC | HarzeM Dilber MC